Source (google cache):

Org url: http://fuppes.ulrich-voelkel.de/forum/viewtopic.php?f=2&t=513

Gday folks. I wanted to share how I got fuppes to compile and work on Ubuntu 9.04, Jaunty. I've tested it with my PS3 and its working fine. I have not completed all the tests and setup so this may change into the future. The wiki and guides online had the dependencies of what needs to be installed wrong.

sudo apt-get install build-essential subversion autoconf automake gettext libtool libpcre3-dev libxml2-dev libsqlite3-dev libfaad-dev libmad0-dev libflac-dev libmagick++-dev libvorbis-dev libtwolame-dev libmpcdec-dev uuid-dev libavformat-dev libavutil-dev libavcodec-dev libmpeg4ip-dev libmp4v2-dev libtag1-dev libexpat1-dev

svn co https://fuppes.svn.sourceforge.net/svnroot/fuppes/trunk fuppes
cd fuppes/
autoreconf -vfi
./configure --prefix=/usr
make
sudo make install
make distclean

Now edit the cfg as you need. For the PS3 firmware v 2.70 onwards you'll need:


UPnP/1.0 DLNADOC/1.50
PLAYSTATION3

and to play dixv / xvid / mpeg4-asp


VIDEO_ITEM
video/x-divx