I just talked to a Debian devel, and all he said not to upgrade, since all packages are chaging placed, and there must be like 1*10^6 dependisies problems.
Solution: see below
Else read this official packmanager guide:
Suggested solution:
Add sarge to

/etc/apt/sources.list .

make new file/correct existing file:
Package: *
Pin: release a=stable
Pin-Priority: 1001

Package: *
Pin: release a=testing
Pin-Priority: 500

Package: *
Pin: release a=unstable
Pin-Priority: 50

then: aptitude update && aptitude dist-upgrade.

This sould preform a susessfull downgrade.